[1.8] Macro/Keybind Mod Download


Macro Keybind Mod [1.8] Macro/Keybind Mod Download

Features:

  • Ridiculously easy to use! Just activate the mod then just press the key you want to bind. No memorizing key codes or names!
  • Bind keys which are already used for something else! Want to put a macro on the number keys or WASD? Using the override function you can use these keys for both their normal function or as macros when you need them.
  • Edit keybinds quickly. Change your binds whenever you want. You can even copy and move macros from key to key with drag ‘n drop.
  • Multiple configurations. Different binds in different servers? No problem! It even switches automatically.
  • In-game text editor. Want to make a complex macro? No need to alt-tab to notepad, create and edit text files inside minecraft.
  • Lots of easy-to-use parameters. Lists of friends, automatic responses, warp points, towns, you name it.
  • Scripting! Build custom auto-announcers, time-delay messages, or create your own auto-walk, toggleable-sneak or sprint keys.
  • Custom GUIs! Create your own custom GUI and hook up your macros for instant in-game menus

Introducing Liteloader:

LiteLoader is a lightweight mod bootstrapping system designed to provide very basic loader functionality for mods which only require a ModLoader-eque onTick. It is designed to run alongside ModLoader but can be updated more quickly than ModLoader because of the extremely reduced functionality. It can not load ModLoader mods but will not interfere with them either.

How to install Liteloader:

  • Download the latest version of LiteLoader by clicking the link below, or choose the version for your version of Minecraft.
  • Open your minecraft .jar with WinRAR or 7-zip:
    • Click Start -> Run (if you don’t see “Run” try holding down your “Windows” key and press the R key)
    • Type %APPDATA% and click OK
    • Open .minecraft and then bin
    • Open minecraft.jar using WinRAR or 7-zip
  • Delete the META-INF folder
  • Drag all the files from the liteloader .zip into your minecraft jar

How to install Macro / Keybind Mod:

  • Install LiteLoader
  • Download the .litemod file for your version of minecraft and save it into your “mods” folder (create the “mods” folder if it does not already exist) NOTE: Some browsers will change the file extension to .zip when downloading, if this happens be sure to change it back to .litemod or LiteLoader will not find the mod!
  • Run the Minecraft client
  • Check the Controls screen in the Minecraft configuration to make sure there are no conflicts with other keys you use. This mod adds pages to the Controls screen for enhanced configuration of any mods which add custom keys

To bind keys:

  • In-game, simply press [SNEAK KEY]+GRAVE (change the key in the options if this doesn’t work for you) and you will be prompted to press a key.
  • Press the key you would like to bind or click it on the on-screen keyboard
  • Enter the chat command (including the / at the start), separate multiple commands with pipe “|”
  • Press ENTER to save the keybind, press ESC to cancel it. To edit a keybind repeat the same process.

To use keybinds:

  • If the key doesn’t have any other function (eg. it is not bound to any other built-in command or function) then just press the key
  • If the key is bound to another function (such as the WASD keys or T,I etc) press your [MACRO ACTIVATE] key (as you set in the options) followed by the key.
  • Alternatively if the key is bound to another function press [MACRO OVERRIDE]+[KEY] (again, you can set this in the Controls screen)

How to install Macro/Keybind Mod:

  • Install LiteLoader
  • Download the .litemod file for your version of minecraft and save it into your “mods” folder (create the “mods” folder if it does not already exist) NOTE: Some browsers will change the file extension to.zip when downloading, if this happens be sure to change it back to .litemod or LiteLoader will not find the mod!
  • Run the Minecraft client
  • Check the Controls screen in the Minecraft configuration to make sure there are no conflicts with other keys you use. This mod adds pages to the Controls screen for enhanced configuration of any mods which add custom keys

More posts of Macro/Keybind Mod :

3 Comments

  1. TangyClarke
    July 23, 2015, 4:54 pm

    I am a staff member on a server that mainly uses the 1.8 version of Minecraft, they are planning to fully update to 1.8 shortly. This mod would be very useful to answer questions quickly in chat to satisfy the players. However, whenever I attempt to run this mod, my Minecraft crashes. This is the crash report I get:

    —- Minecraft Crash Report —-
    // Everything’s going to plan. No, really, that was supposed to happen.

    Time: 23/07/15 17:50
    Description: Unexpected error

    java.lang.IncompatibleClassChangeError: Found class com.mumfrey.liteloader.util.Input, but interface was expected
    at net.eq2online.macros.input.InputHandlerModuleJInput.(InputHandlerModuleJInput.java:90)
    at net.eq2online.macros.core.MacroModCore.initInputHandler(MacroModCore.java:365)
    at net.eq2online.macros.core.MacroModCore.onTickInGUI(MacroModCore.java:844)
    at net.eq2online.macros.LiteModMacros.onTick(LiteModMacros.java:127)
    at com.mumfrey.liteloader.core.event.HandlerList$Tickable9.onTick(HandlerList$Tickable9.java:100)
    at com.mumfrey.liteloader.client.LiteLoaderEventBrokerClient.onTick(LiteLoaderEventBrokerClient.java:406)
    at com.mumfrey.liteloader.client.CallbackProxyClient.onTick(CallbackProxyClient.java:69)
    at com.mumfrey.liteloader.core.event.EventProxy.$event00005(EventProxy.java:216)
    at bsu.as(SourceFile:903)
    at bsu.a(SourceFile:314)
    at net.minecraft.client.main.Main.main(SourceFile:120)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    A detailed walkthrough of the error, its code path and all known details is as follows:
    —————————————————————————————

    — System Details —
    Details:
    Minecraft Version: 1.8
    Operating System: Windows 8.1 (amd64) version 6.3
    Java Version: 1.8.0_25, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 226358504 bytes (215 MB) / 636485632 bytes (607 MB) up to 5726797824 bytes (5461 MB)
    Mod Pack: 1.8-SNAPSHOT-r369-b49-2015-05-28_00-04-54
    LiteLoader Mods: 1 loaded mod(s)
    – Macro / Keybind Mod version 0.11.1 beta 1
    LaunchWrapper: 9 active transformer(s)
    – Transformer: com.mumfrey.liteloader.transformers.event.EventProxyTransformer
    – Transformer: com.mumfrey.liteloader.launch.LiteLoaderTransformer
    – Transformer: com.mumfrey.liteloader.client.transformers.CrashReportTransformer
    – Transformer: com.mumfrey.liteloader.transformers.event.EventTransformer
    – Transformer: com.mumfrey.liteloader.common.transformers.LiteLoaderPacketTransformer
    – Transformer: com.mumfrey.liteloader.client.transformers.LiteLoaderEventInjectionTransformer
    – Transformer: com.mumfrey.liteloader.client.transformers.MinecraftTransformer
    – Transformer: net.eq2online.macros.input.InputHandlerInjector
    – Transformer: com.mumfrey.liteloader.transformers.event.json.ModEventInjectionTransformer
    JVM Flags: 2 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx6G
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    Launched Version: 1.8
    LWJGL: 2.9.1
    OpenGL: Intel(R) HD Graphics 4400 GL version 4.2.0 – Build 10.18.10.3574, Intel
    GL Caps: Using GL 1.3 multitexturing.
    Using GL 1.3 texture combiners.
    Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
    Shaders are available because OpenGL 2.1 is supported.
    VBOs are available because OpenGL 1.5 is supported.

    Using VBOs: No
    Is Modded: Definitely; Client brand changed to ‘LiteLoader’
    Type: Client (map_client.txt)
    Resource Packs: [Eum3s PvP Faithful Edit 1.8.zip]
    Current Language: English (UK)
    Profiler Position: N/A (disabled)

    A bit of help would be greatly appreciated as I would love to use this mod on 1.8 Minecraft! Thank you very much!

  2. Guest
    August 28, 2015, 9:36 pm

    that’s for beta 1.8

  3. somone
    April 25, 2016, 4:34 am

    same thing happened to me it crashes my mc so yea and I realy want to use it

Leave a Reply

Macro/Keybind Screenshots

mod macros shot15 Macro/Keybind Screenshots

Macro Keybind Mod 2 Macro/Keybind Screenshots

Auto-populate towns, homes, friends

Macro Keybind Mod 3 Macro/Keybind Screenshots

Friend selection

Macro Keybind Mod 4 Macro/Keybind Screenshots

Item selection

Macro Keybind Mod 5 Macro/Keybind Screenshots